Back to overview
Resolved

Sign-in delays caused by an upstream authentication provider incident

Jul 16, 2026 at 8:17am UTC
Affected services
Main App

Resolved
Jul 16, 2026 at 10:13am UTC

The upstream authentication provider has resolved their incident and sign-in performance has returned to normal. Authentication requests are completing in well under a second again and we are seeing no further timeouts. This incident is resolved.

Created
Jul 16, 2026 at 8:17am UTC

Our upstream authentication provider (WorkOS) is experiencing an ongoing incident with elevated API latency and timeouts. New sign-ins may load slowly, show a spinner, or fail with a gateway timeout. Users with an active session are largely unaffected, though session refreshes may occasionally be slow. The Lleverage platform itself is healthy and workflow execution is unaffected. We are monitoring the upstream incident and will post updates here as it progresses.